Cuda-Treiber für OS 10.4.11

Forum für verschiedenste Hard- und Softwareprobleme.

Moderatoren: Indio, Frank Vogelskamp, danny, dr.f, Nico

suda
Senior Cutter
Beiträge: 697
Registriert: 07.12.2010, 20:04
Firma: Attigfilm
Kontaktdaten:

Cuda-Treiber für OS 10.4.11

Beitrag von suda » 30.05.2021, 01:03

Hallo,

ich möchte meinen Power Mac G4 (Quicksilver) auf dem die letztmögliche Betriebssytem-Version Tiger ( 10.4.11 ) installiert ist mit FCP 7.03 (am Filmabtaster ) verwenden. Im G4 steckt eine Nvidia-Grafikkarte für deren Betrieb ein Cuda-Treiber notwendig ist. Auf der CUDA-Seite sind jedoch nur Treiber für die neueren Betriebssyteme verfügbar.

Wer kann sagen wo ich einen Cuda-Treiber für OS 10.4.11 heruntergeladen werden kann ?

Mit freundlichen Grüßen, Hans

claudio
Junior Cutter
Beiträge: 146
Registriert: 01.04.2005, 11:36

Re: Cuda-Treiber für OS 10.4.11

Beitrag von claudio » 30.05.2021, 09:07


Benutzeravatar
Nico
Final Cut Director 10K+
Beiträge: 15694
Registriert: 14.07.2004, 18:00

Re: Cuda-Treiber für OS 10.4.11

Beitrag von Nico » 30.05.2021, 17:36

FCP7.3 für PPC, war das noch Universal, dachte nur noch Intel. Auf jeden Fall ist CUDA ein extra Treiber für proprietäres GPGPU und nicht Teil des grundsätzlichen Grafiktreibers. FCP hat mit CUDA eh nix am Hut. Um welche Grafikkarte handelt es sich denn? Ich meine Grafikkarten mit extra CUDA-fähigen Grafikkernen gab es zur Zeit von 10.4.11 und PowerPC noch nicht.

Edit: Für keine Nvidia-Karte ist für deren Betrieb CUDA notwendig. Das war immer ein zusätzliches Add-on und setzte Software voraus, die auch für Berechnungen CUDA einsetzt. Für einige Grafikkarten konnte man allerdings alternativ zu den vorhandenen Apple-Treibern bei bestimmten Modellen sogenannte „Web-driver“ nutzen.
Ordnung ist die primitivste Form von Chaos. (Hans-Jürgen Quadbeck-Seeger)

Benutzeravatar
Nico
Final Cut Director 10K+
Beiträge: 15694
Registriert: 14.07.2004, 18:00

Re: Cuda-Treiber für OS 10.4.11

Beitrag von Nico » 31.05.2021, 08:13

Nee, nix CUDA. Im G4 wurde gerade mal der Wechsel von PCI auf AGP vollzogen. Grafikspeicher wurde hier noch im zweistelligen MB(!)-Bereich gezählt.
Später im G5 dann PCI-X und recht zum Schluss dieser Ära PCIe.
Daran war beim G4 nicht zu denken. In 10.4.x war auch noch nix beschleunigt, das ging mit 10.5.x los. Der Meilenstein war dann 10.6.x, ab hier schon längst Intel Mac Pro.
Ordnung ist die primitivste Form von Chaos. (Hans-Jürgen Quadbeck-Seeger)

suda
Senior Cutter
Beiträge: 697
Registriert: 07.12.2010, 20:04
Firma: Attigfilm
Kontaktdaten:

Re: Cuda-Treiber für OS 10.4.11

Beitrag von suda » 31.05.2021, 12:32

Hallo Nico,
danke für die Antwort.
Den G4 benutze ich nur am Filmabtaster mit der AJA IO-Box. All´ die Jahre hat der auch normal funktioniert. Dann stand das Ganze 2 Jahre.

Nun habe ich aber Tiger ( 10.4.11) installiert und FCP 4 installiert. Seitdem kommt beim Start von FCP 4 die Fehlermeldung : "Es wird eine bestimmte Hardware oder Software benötigt, die aber fehlt - AGP-Grafikkarte."

Mit FCP 3 kommt diese Fehlermeldung nicht, allerdings kann ich in die FCP -Voreinstellungen nicht die AJA-Einstellungen installieren deshalb FCP 4, wo sich die AJA-Einstellungen installieren lassen.

Mit derselben Grafikkarte ( NVIDIA) funktionierte FCP (Loggen und Aufnehmen ) aber bisher mit der AJA IO-Box. Allerdings wurde der G4 nun neu "aufgesetzt" und wahrscheinlich war bis dahin ein älteres Betriebssystem und ein älteres FCP drauf ( schwache Erinnerung bei mir).

Daraufhin habe ich eine Grafikkarte "ATI" 9600 - AGP_Karte für Mac eingesteckt und einen Ati-Treiber installiert. Aber diese Karte wird nicht erkannt. Also ist nun wieder die bisherige Karte eine Nvidia drin.

Im Forum "MacUser.de" habe ich um Hilfe nachgesucht. Aber auch da konnte man nicht weiterhelfen. Mir wurde mitgeteilt, daß das Problem wahrscheinlich mit FCP zusammenhängt.

Meine Frage : hängt die ganze Problematik mit FCP zusammen ? Wenn ja, was ist zu ändern ?

Mit frendlichen Grüßen
Hans-Joachim

Benutzeravatar
Nico
Final Cut Director 10K+
Beiträge: 15694
Registriert: 14.07.2004, 18:00

Re: Cuda-Treiber für OS 10.4.11

Beitrag von Nico » 31.05.2021, 14:45

Ist echt lange her … :)

Mac OS X 10.4.x für deinen G4 ist richtig. Welches FCP damit optimal läuft, weiß ich nicht. Wenn das "neuere" FCP4 eine AGP-Grafikkarte verlangt, aber keine solche verbaut ist (nur PCI), dann geht wohl nur FCP3. Das kannst nur du wissen. Das sind verschiedene Bus-Systeme, die "Slots" sehen auch anders aus. Entsprechend auch die Karten mit ihren Kontaktleisten.

Damit dann auch die AJA IO korrekt läuft, sind auch dafür passende Treiber zu installieren. Die findest du glücklicherweise noch auf der Seite vom Hersteller: www.aja.com
Hier auf "Support", dann "Downloads", dann runterscrollen zu "Legacy Products". Dort bei "Io" deine genutzte "Io" wählen und in den alten Treibern stöbern. Da findest du sowohl "aktuelle" Treiber unter "Software", sowie noch ältere unter "Software Archive".


EDIT:
Wenn die AGP-Grafikkarte (ATI), die eigentlich laufen sollte, eine "x8" ist, dein AGP aber nur "x4", dann müssen bei der Karte zwei Pins abgeklebt (isoliert) werden, da sich bei Apple diesbezüglich etwas geändert hatte. Ansonsten lag da etwas unkorrekt auf Masse, und dann lief es nicht. Welche Pins das sind, weiß ich nu nicht mehr. Aber Google wird dir helfen können …

EDIT2:
schau mal hier:
https://www.macuser.de/threads/schnells ... g4.749933/
Ordnung ist die primitivste Form von Chaos. (Hans-Jürgen Quadbeck-Seeger)

suda
Senior Cutter
Beiträge: 697
Registriert: 07.12.2010, 20:04
Firma: Attigfilm
Kontaktdaten:

Re: Cuda-Treiber für OS 10.4.11

Beitrag von suda » 31.05.2021, 18:13

Hallo Nico,
danke für die Hinweise. Zwar hatte ich eben schon nach den Treibern auf der AJA-Seite gesucht aber die IO nicht gefunden. Mit Deinen jetzigen Hinweisen versuche ich es gleich nochmal.

Freundliche Grüße

Hans

suda
Senior Cutter
Beiträge: 697
Registriert: 07.12.2010, 20:04
Firma: Attigfilm
Kontaktdaten:

Re: Cuda-Treiber für OS 10.4.11

Beitrag von suda » 31.05.2021, 19:12

Hallo Nico,

.....es hat funktioniert !!! Nach Deinem sehr gut beschriebenem Hinweis habe ich die Treiber für die AJA IO schnell gefunden, heruntergeladen und auf dem G4 installiert. Nun sind die AJA-Einstellungen in den Audio/Video-Voreinstellungen in FCP zu sehen und anwendbar.
So soll es sein. Die AJA IO wird als Bindeglied zwischen dem RGB-Ausgang meines Filmabtasters BOSCH FDL 60 und
dem G4 gebraucht ( FDL 60-RGB-Ausgang auf die AJA IO, von dort per FireWire zum G4 ).

Jetzt gehe ich an das nächste Problem : ich habe 3 Filmabtaster BOSCH FDL 60. Nach langer Standzeit funktioniert keiner mehr !!!!!!!!!!!
Kennst Du Dich zufällig auch mit diesen Geräten aus ? Das ist ist nur eine Frage.
An diesen Geräten gibt es vielfältige Fehlermöglichkeiten mit vielen IC´s auf zahlreichen Platinen. Die Fehlersuche ist wie die Suche nach einer Stecknadel im Heuhaufen.

Danke nochmal , Gruß Hans

Benutzeravatar
Nico
Final Cut Director 10K+
Beiträge: 15694
Registriert: 14.07.2004, 18:00

Re: Cuda-Treiber für OS 10.4.11

Beitrag von Nico » 01.06.2021, 17:47

leider null Plan … :)
Ordnung ist die primitivste Form von Chaos. (Hans-Jürgen Quadbeck-Seeger)

Antworten